ОбъектЗаказа = ЗаказСсылка.ПолучитьОбъект();
Если ОбъекЗаказа.ЗаблокированПоФирме() Тогда
	Отказ = Истина;
КонецЕсли;

Добавлено анонимнусом 11.08.2017 07:19:59

Просмотреть запись целиком.


// Возвращаемое значение:
//		Структура
//			- Успех 		  - Булево
//			- КемЗаблокирован - Строка
//			- ОписаниеОшибки  - Строка
Функция ЗаблокироватьРедактированиеПоФирме(Фирма, УникальныйИдентификаторФормы = Неопределено) Экспорт

Процедура РазблокироватьРедактированиеПоФирме(Фирма, Уникал

Добавлено анонимнусом 11.08.2017 07:15:29

Просмотреть запись целиком.


ВЫБРАТЬ
	ТабельПоФТТЗарплатаФТТ.Сотрудник КАК Продавец,
	СУММА(ВЫБОР
			КОГДА ТабельПоФТТЗарплатаФТТ.ВидВыработки.Наименование = "01-Продукция МЦ и ЦЗ"
				ТОГДА ЕСТЬNULL(ТабельПоФТТЗарплатаФТТ.РасчетЗП, 0)
		КОНЕЦ) КАК ВидВ1,
	СУММА(ВЫБОР
			КОГДА ТабельПоФТТЗарплатаФТТ.ВидВыработки.Наименов

Добавлено анонимнусом 05.08.2017 04:32:29

Просмотреть запись целиком.


[
{
"Код": "643",
"Наименование": "РОССИЯ",
"НаименованиеПолное": "Российская Федерация",
"КодАльфа2": "RU",
"КодАльфа3": "RUS"
},
{
"Код": "895",
"Наименование": "АБХАЗИЯ",
"НаименованиеПолное": "Республика Абхазия",
"КодАльфа2": "AB",
"КодАльфа3": "ABH"
},
{
"Код": "036",
"Наимено

Добавлено анонимнусом 02.08.2017 04:19:10

Просмотреть запись целиком.


Код Из Марки

Функция ПолучитьИдТовараСмарки(НомерМарки)
	//Ладно, это проверка валидности, пусть будет.
	Если СтрДлина(НомерМарки) <> 68 Тогда
		Возврат Неопределено;
	Иначе
		//Извлекаем алкокод в системе Base36
		АлкоКод36 = Сред(НомерМарки, 4, 16);

		//Преобразуем в число
		Алкокод = 0;
		Для Счётч

Добавлено анонимнусом 27.07.2017 07:37:11

Просмотреть запись целиком.


Алкокод из акцизной марки

// возвращает алк код товара из штрихкода марки
Функция ПолучитьИдТовараСмарки(НомерМарки)

ИТР = 0;

Значение = СокрЛП(НомерМарки);
Если СтрДлина(Значение) <> 68 Тогда
Возврат Неопределено;
Иначе
Если Сред(Значение, 4, 5) = "00000" тогда
Значение = Сред(Значение, 9, 11);
ИТР = 11;
Иначе

Добавлено анонимнусом 27.07.2017 07:04:46

Просмотреть запись целиком.


Процедура Пересчет(П=0)
	МинСуммаДоставки = Константа.МинимальнаяСуммаДоставки;
	Если П=0 Тогда
		Если КоличествоСтрок()=0 Тогда
			СуммаЗД=0;
			Возврат;
		КонецЕсли;		
		ИтСумма=Итог("Сумма");
	Иначе
		Если КоличествоСтрок()=1 Тогда
			СуммаЗД=0;
			Возврат;
		КонецЕсли;		
		ИтСумма=И

Добавлено анонимнусом 19.07.2017 12:53:21

Просмотреть запись целиком.


 &НаКлиенте
Процедура СоздатьДокумент(Команда)
Форма = ПолучитьФорму("Документ.Реализация.ФормаОбъекта");
ДанныеФормы = Форма.Объект;
ЗаполнитьДокументНаСервере(ДанныеФормы);
КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
Форма.Открыть();
КонецПроцедуры

&НаСервере
Функция ЗаполнитьДоку

Добавлено анонимнусом 19.07.2017 12:13:06

Просмотреть запись целиком.


123

ПараметрыДействийСхемы = Справочники.СхемыКомплексныхПроцессов.ПараметрыДействийСхемы(Процесс.Схема);

ПараметрыПодписания = ПараметрыДействийСхемы.Найти("Действие3");

СостояниеПодписания = Перечисления.СостоянияДокументов.Подписан;
УстановилСостояние = ПараметрыПодписания.Процесс;

Делопрои

Добавлено анонимнусом 19.07.2017 12:06:11

Просмотреть запись целиком.


objRootLDAP = ПолучитьCOMОбъект("LDAP://rootDSE");
objContainer = ПолучитьCOMОбъект("LDAP://"+ПутьАД+",DC=domen,DC=ru");
strCN = РС.ПользовательАД ;
strSam = РС.ПочтаАД;
strPWD = РС.Пароль;
objUser = objContainer.Create("User", "CN=" +CтрокаФамилия+" "+СтрокаИмя);
objUser.Put("name", CтрокаФам

Добавлено анонимнусом 18.07.2017 19:58:31

Просмотреть запись целиком.


Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
	// ЭлектронныеДокументы
	ЭлектронныеДокументыПереопределяемый.УстановитьСтатусПодключенияК1СЭДО(Элемент, ОформленияСтрок);
	// Конец ЭлектронныеДокументы
КонецПроцедуры

Добавлено анонимнусом 13.07.2017 21:16:57

Просмотреть запись целиком.


Процедура УстановитьСтатусПодключенияК1СЭДО(Элемент, ОформленияСтрок) Экспорт
    нзСостоянияКонтрагентов = РегистрыСведений.СостоянияКонтрагентовБЭД.СоздатьНаборЗаписей();
	ЭлементОтбора = нзСостоянияКонтрагентов.Отбор.Контрагент;
	ЭлементОтбора.ВидСравнения = ВидСравнения.Равно;
	ЭлементОтбора

Добавлено анонимнусом 13.07.2017 21:05:11

Просмотреть запись целиком.


пакакп

Добавлено анонимнусом 12.07.2017 02:51:19

Просмотреть запись целиком.


xdtoСправочник = сшпОбщегоНазначения.ПолучитьОбъектXDTO(Перечисления.сшпФорматыСообщений.XML, ОбъектСообщение.Body);

Попытка		
    
    ID = Строка(xdtoСправочник.ID);		
    
    НачатьТранзакцию();
    
    БлокировкаДанных = Новый БлокировкаДанных;
    ЭлементБлокировки = БлокировкаДанны

Добавлено анонимнусом 10.07.2017 23:57:58

Просмотреть запись целиком.


РезультатОбработки.ClassID = "Employee";	
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ИОКЛ.Идентификатор КАК ID,
	|	0 КАК Code,
	|	ФизическиеЛица.Наименование КАК Name,
	|	ВЫБОР
	|		КОГДА ФизическиеЛица.Родитель = ЗНАЧЕНИЕ(Справочник.ФизическиеЛица.ПустаяСсылка)
	|			ТОГДА ""Про

Добавлено анонимнусом 06.07.2017 06:19:09

Просмотреть запись целиком.


xdtoСправочник = сшпОбщегоНазначения.ПолучитьОбъектXDTO(Перечисления.сшпФорматыСообщений.XML, ОбъектСообщение.Body);
	
	Попытка		
		
		ID = Строка(xdtoСправочник.ID);
		
		НачатьТранзакцию();
		
		БлокировкаДанных = Новый БлокировкаДанных;
		ЭлементБлокировки = БлокировкаДанных.Добавить("Ре

Добавлено анонимнусом 06.07.2017 04:02:13

Просмотреть запись целиком.


код

&НаКлиенте
Процедура АктивПриИзменении(Элемент)
	//Шумилин ==> 24.01.2017
	ПоказатьОткрытыеЗаявкиНаСервере();
	//Шумилин <== 24.01.2017	
	Если Актив = ПредопределенноеЗначение("Справочник.ВТК_Активы.ПустаяСсылка") Тогда
		Элементы.СостояниеСервиса.Видимость = Ложь;
	Иначе
		Элементы.Состояни

Добавлено анонимнусом 30.06.2017 12:57:21

Просмотреть запись целиком.


куку

Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
	ПараметрыРегистрации.Вставить("Назначение", );
	ПараметрыРегистрации.Вставить("Наименование", "Отражение доходов и расходов по претензии");
	Па

Добавлено анонимнусом 30.06.2017 06:59:30

Просмотреть запись целиком.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Месяц = Формат(Объект.ПериодРегистрации, "ДФ='MMMM yyyy'");
	СформироватьСписокВыбораМесяца(Год(Объект.ПериодРегистрации));
КонецПроцедуры

Процедура СформироватьСписокВыбораМесяца(Год)
    
    Элементы.Месяц.СписокВыбора.Очистить();
    Элементы.Ме

Добавлено анонимнусом 28.06.2017 07:50:42

Просмотреть запись целиком.


ВЫБРАТЬ
	Номенклатура.Ссылка,
	Номенклатура.Наименование,
	Номенклатура.Артикул,
	Номенклатура.Код,
	Номенклатура.База,
	Номенклатура.КодСУП
ПОМЕСТИТЬ АлкогольСсупКодами
ИЗ
	Справочник.Номенклатура КАК Номенклатура
ГДЕ
	Номенклатура.Наименование ПОДОБНО "%[0-9][0-9][0-9][0-9][0-9][0-9][0-

Добавлено анонимнусом 26.06.2017 13:50:02

Просмотреть запись целиком.