//удалить	
	НаборЗаписей1 = РегистрыСведений.СчетаНалоговогоУчетаОС.СоздатьНаборЗаписей(); 
	
	НаборЗаписей1.Отбор.Регистратор.Установить(ДокументРегистратор); 
	НаборЗаписей1.Отбор.ОсновноеСредство.Установить(ОсновноеСредство); 
	НаборЗаписей1.Отбор.Организация.Установить(Организация);
	
	Н

Добавлено анонимнусом 22.02.2018 11:13:38

Просмотреть запись целиком.


	ОткрытыеОкна = ПолучитьОкна();
	
	Для Каждого ОткрОкно Из ОткрытыеОкна Цикл
		Если ОткрОкно.Заголовок = Строка(ОбъектыНазначенияМассив[0]) Тогда 
			ОткрОкно.Содержимое[0].ЭтаФорма.ОбновитьОтображениеДанных(ОткрОкно.Содержимое[0].ЭтаФорма.Элементы.ГруппаНачисленнаяЗарплатаИВзносы);
			Прервать

Добавлено анонимнусом 21.02.2018 12:25:44

Просмотреть запись целиком.


	Ссылка = МассивОбъектов[0];
	ОбъектСсылка = Ссылка.ПолучитьОбъект();
   	Отбор = Новый Структура;
	Отбор.Вставить("ВидОперации",Перечисления.ВидыОперацийПоЗарплате.ЕжегодныйОтпуск);
	СтрокиОтбора = ОбъектСсылка.НачисленнаяЗарплатаИВзносы.НайтиСтроки(Отбор);
	СсылкаОтражения = Справочники.Спосо

Добавлено анонимнусом 21.02.2018 12:22:03

Просмотреть запись целиком.


ВЫБРАТЬ
	НДСЗаписиКнигиПродаж.Период КАК Период,
	НАЧАЛОПЕРИОДА(ВЫБОР
			КОГДА НДСЗаписиКнигиПродаж.ЗаписьДополнительногоЛиста
				ТОГДА НДСЗаписиКнигиПродаж.КорректируемыйПериод
			ИНАЧЕ НДСЗаписиКнигиПродаж.Период
		КОНЕЦ, КВАРТАЛ) КАК НалоговыйПериод,
	КОНЕЦПЕРИОДА(ВЫБОР
			КОГДА НДСЗапис

Добавлено анонимнусом 21.02.2018 07:11:20

Просмотреть запись целиком.


1

exec sp_executesql N'SELECT TOP 45
T1._IDRRef,
T1._Fld631,
T1._Fld630,
T1._Fld628RRef,
T1._Fld629RRef,
T1._Fld627RRef,
T1._Fld632RRef,
T1._Fld635RRef,
T1._Fld636,
ISNULL(T2._Fld3787RRef,0x00000000000000000000000000000000),
CASE WHEN (T2._Fld3787RRef = 0x9A20E01FB131EB8044A45334F0A4688E) T

Добавлено анонимнусом 20.02.2018 09:45:03

Просмотреть запись целиком.


1

exec sp_executesql N'SELECT TOP 45
T1._IDRRef,
T1._Fld631,
T1._Fld630,
T1._Fld628RRef,
T1._Fld629RRef,
T1._Fld627RRef,
T1._Fld632RRef,
T1._Fld635RRef,
T1._Fld636,
ISNULL(T2._Fld3787RRef,0x00000000000000000000000000000000),
CASE WHEN (T2._Fld3787RRef = 0x9A20E01FB131EB8044A45334F0A4688E) T

Добавлено анонимнусом 20.02.2018 07:32:36

Просмотреть запись целиком.


Фрагмент

Процедура Процедура1(ФормальныйПараметр1)

        ФормальныйПараметр1 = 2 * 3;

КонецПроцедуры

ФактическийПараметр = 10;
Процедура1(ФактическийПараметр);

// будет выведено значение 6 - изменение формального
// параметра внутри процедуры повлияло на изменение
// значения фактического па

Что-то там

Добавлено анонимнусом 16.02.2018 02:42:45

Просмотреть запись целиком.


Процедура Процедура1(ФормальныйПараметр1)

        ФормальныйПараметр1 = 2 * 3;

КонецПроцедуры

ФактическийПараметр = 10;
Процедура1(ФактическийПараметр);

// будет выведено значение 6 - изменение формального
// параметра внутри процедуры повлияло на изменение
// значения фактического па

Добавлено анонимнусом 16.02.2018 02:42:15

Просмотреть запись целиком.



&НаСервере
Процедура ВсеРолиНаСервереСтар()
	
	тз = Новый ТаблицаЗначений;
	тз.Колонки.Добавить("Роль");
	тз.Колонки.Добавить("Объект");
	тз.Колонки.Добавить("Чтение");
	тз.Колонки.Добавить("Запись");
	
	Для й = 0 по Метаданные.Роли.Количество() - 1 Цикл
		Для Каждого текДок из Метаданны

Добавлено анонимнусом 13.02.2018 01:26:03

Просмотреть запись целиком.


тз с ролями

&НаСервере
Процедура ВсеРолиНаСервере()
	
	тз = Новый ТаблицаЗначений;
	тз.Колонки.Добавить("Роль");
	тз.Колонки.Добавить("Объект");
	тз.Колонки.Добавить("Чтение");
	тз.Колонки.Добавить("Запись");
	
	Для й = 0 по Метаданные.Роли.Количество() - 1 Цикл
		Для Каждого текДок из Метаданные.Доку

Добавлено анонимнусом 12.02.2018 03:37:35

Просмотреть запись целиком.


запрос мой

ВЫБРАТЬ
	СвязанныеДокументы.СвязанныйДокумент КАК СвязанныйДокумент
ПОМЕСТИТЬ Вр_СвязанныеДокументы
ИЗ
	РегистрСведений.СвязанныеДокументы КАК СвязанныеДокументы
ГДЕ
	СвязанныеДокументы.ТипСвязи = ЗНАЧЕНИЕ(Перечисление.ТипыСвязи.Основание)

ИНДЕКСИРОВАТЬ ПО
	СвязанныйДокумент
;

////////

Добавлено анонимнусом 08.02.2018 14:04:03

Просмотреть запись целиком.


#include <iostream>
#include <iomanip>
#include <cmath>
#include <fstream>
#include <vector>
using namespace std;

double znach (double a, double b, double c, double x);
void znach2 (int **M, double C, double *y, int n);
int MaxZnach(double *y, int n);
int rul_number (double  ** R, int X_F

Добавлено анонимнусом 08.02.2018 08:08:19

Просмотреть запись целиком.


test

	Запрос = Новый Запрос;
	Запрос.Текст = ТекстЗапроса;
	Запрос.УстановитьПараметр("ПроектДокумента"				   	, Объект.Проект);
	Запрос.УстановитьПараметр("ПодразделениеДокумента"		   	, Объект.Подразделение);
	Запрос.УстановитьПараметр("МесяцПланирования"			   	, Объект.МесяцПланирования);
	Запрос

Добавлено анонимнусом 08.02.2018 05:28:37

Просмотреть запись целиком.


ВЫБРАТЬ
						|	ФОТ.Организация КАК Организация,
						|	ФОТ.Подразделение КАК Подразделение,
						|	ФОТ.ПФР КАК ПФР,
						|	""ПФР"" КАК ВидНалога
						|ИЗ
						|	ФОТ КАК ФОТ
						|
						|ОБЪЕДИНИТЬ ВСЕ
						|
						|ВЫБРАТЬ
						|	ФОТ.Организация,
						|	ФОТ.Подразделение,
			

Добавлено анонимнусом 07.02.2018 13:21:22

Просмотреть запись целиком.


Х

Привет дай денег

Добавлено анонимнусом 05.02.2018 06:25:14

Просмотреть запись целиком.


Различия кода 3-0-18-11 и 3-0-18-12


	***- Объект изменен
	-->- Объект присутствует только в основной конфигурации
	<--- Объект присутствует только в новой конфигурации поставщика
	^- Порядок объекта изменен

	- ***ОбщийМодуль.ПроведениеРасчетовСервер
		- Модуль - Различаются значения
			Изменено: 2571 - 2571
			< "··Предоста

Добавлено анонимнусом 31.01.2018 15:29:54

Просмотреть запись целиком.


ЛПИ.Запрос = Новый Запрос;

ЛПИ.Запрос.Текст = 
			"ВЫБРАТЬ
			|	ДокументЗапроса.Ссылка
			|ИЗ
			|	" + ЛПИ.Правило.ИмяОбъектаДляЗапроса + " КАК ДокументЗапроса
			|ГДЕ
			|	ДокументЗапроса.ОтчетныйПериод.ДатаНачала >= &ДатаНачала 
			|
			|УПОРЯДОЧИТЬ ПО
			|	ДокументЗапроса.Дата";


Добавлено анонимнусом 25.01.2018 12:06:17

Просмотреть запись целиком.


ЛПИ = Новый Структура(
	"Правило, ВыборкаДанных, Запрос, ТаблицаДокументы, ИмяДокумента, ОбъектМетаданныхДокумент, ТекстОтбораПоУчреждению, ЗначениеПустаяДата,ИтоговоеОграничениеПоДате");

ЛПИ.Правило = ВходящиеМГУ_ПолучитьВыборкуДокументов.Правило;
ЛПИ.ЗначениеПустаяДата = Дата('00010101');
ЛП

Добавлено анонимнусом 25.01.2018 09:08:57

Просмотреть запись целиком.


гсч

Функция ПолучитьСлучайноеЧисло(Мин,Макс) Экспорт 

//вместо Randomize 
Для н = 1 По 100 Цикл 
Уник = Новый УникальныйИдентификатор; 
КонецЦикла; 

//генерируем GUID 
Уник = СокрЛП(Новый УникальныйИдентификатор); 

//оставляем только цифры 
Уник = СтрЗаменить(Уник,"-",""); 
Уник = СтрЗаме

Добавлено анонимнусом 24.01.2018 02:41:49

Просмотреть запись целиком.


Ну=1;

Добавлено анонимнусом 17.01.2018 04:30:45

Просмотреть запись целиком.